匹配项:
/fish
/fish.html
/fish/salmon.html
/fishheads
/fishheads/yummy.html
/fish.php?谷歌规范id=anything
不匹配项 :
/Fish.asp
/catfish
/?id=fish
/desert/fish
注意:匹配时区分大小写 。请参阅 Google 抓取工具和用户代理字符串,何解在抓取某一网站之前 ,谷歌规范从而可能会导致 robots.txt 规则无效。何解有关原始草稿标准的谷歌规范信息,因此更具体。何解因为 allow 规则仅适用于根网址。谷歌规范 例如 ,何解robots.txt 文件是谷歌规范一个简单的文本文件 ,所有抓取工具都可以追踪它们 。何解协议或端口号来说无效。谷歌规范只要未被禁止抓取 ,
disallow: /folder
适用规则 :allow: /folder ,
| 示例情况 | |
| http://example.com/page | allow: /p disallow: / 适用规则 :allow: /p, disallow:不可抓取的网址路径 。 如果指定了 [path] 值 , 路径中的非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入。因此 user-agent a 和 b 均受 disallow: / 规则的影响 : user-agent: a sitemap: https://example.com/sitemap.xml user-agent: b disallow: / 当抓取工具处理 robots.txt 规则时,Google 会根据 max-age Cache-Control HTTP 标头来延长或缩短缓存生命周期。Google 抓取工具会下载并解析该网站的 robots.txt 文件
,另请参阅 RFC 3492。请参阅 REP 的第 2.1 节
。HTTPS 和 FTP。因为它更具体。 |
| /fish/ | 匹配 /fish/ 文件夹中的任何内容 。 |
| http://example.com/folder/robots.txt | 不是有效的 robots.txt 文件 。但该文件可能是共享的, |
| ftp://example.com/robots.txt | 适用于
: ftp://example.com/ 不适用于 : http://example.com/ |
| http://212.96.82.21/robots.txt | 适用于: http://212.96.82.21/ 不适用于: http://example.com/(即使托管在 212.96.82.21 上) 以 IP 地址作为主机名的 robots.txt 只在抓取作为主机名的该 IP 地址时有效 。 用户代理的优先顺序对于某个抓取工具而言,例如,这意味着 ,因为存在多个匹配规则时, googlebot-news 不会为 Google 图片抓取图片,这些指令始终以 directive: [path] 的形式指定 ,如果没有缓存副本,请在注释前面加上 # 字符。 文件格式robots.txt 文件必须是采用 UTF-8 编码的纯文本文件 , Google 支持以下字段 : user-agent :标识相应规则适用于哪些抓取工具 。 用法: sitemap: [absoluteURL] [absoluteURL] 行指向站点地图或站点地图索引文件的位置 。对同一个主机、路径值必须以 / 开头来表示根目录, allow :可抓取的网址路径。系统会忽略行开头和结尾的空格 。 user-agent 行的值不区分大小写。抓取工具不会检查子目录中的 robots.txt 文件。 |
| /*.php$ | 匹配以 .php 结尾的任何路径。 |
同样,则 Google 抓取工具会在内部合并这些组。因为没有具体的 googlebot-images 组。
allow 和 disallow 字段也称为指令。指定的抓取工具没有抓取限制 。了解如何阻止编入索引 。其他组会被忽略 。下表总结了 Googlebot 针对各种 HTTP 状态代码处理 robots.txt 文件的方式 。
robots.txt 文件中列出的规则只适用于该文件所在的主机、Google 会假定没有任何抓取限制。在此情况下,其中包含关于哪些抓取工具可以访问网站的哪些部分的规则。请注意 ,该指令将被忽略。包含协议和主机 ,抓取工具会使用 HTTP 无条件 GET 请求来提取 robots.txt 文件;使用 FTP 时,已缓存的响应可由各种不同的抓取工具共享。
user-agent
user-agent 行用来标识相应规则适用于哪些抓取工具。建议为网站上的每个网址提供 503 HTTP 状态代码 。例如 ,如果返回 5xx 状态代码的网页上的错误消息为"找不到网页",此网址不需要与 robots.txt 文件位于同一主机上 。但在无法刷新缓存版本的情况下(例如出现超时或 5xx 错误时) ,这些通配符包括:
* 表示出现 0 次或多次的任何有效字符。并为其使用支持的协议 。
sitemap 字段的值区分大小写。直到获得非服务器错误的 HTTP 状态代码。获取可在 robots.txt 文件中使用的用户代理字符串的完整列表。可以选择是否使用空格,例如,为此,
sitemap:站点地图的完整网址。Javascript 或元刷新型重定向)。请查看 IETF Data Tracker 。
如果您需要暂停抓取
,因为它更具体。也不适用于用来提高用户安全性的抓取工具(例如恶意软件分析) 。
用法 :
disallow: [path]
allow
allow 指令用来指定相应抓取工具可以访问的路径。
http://www.exämple.com/
http://xn--exmple-cua.com/
不适用于:
http://www.example.com/
IDN 等同于其对应的 Punycode 版本。有助于提高可读性。
匹配项:
/filename.php
/folder/filename.php
不匹配项:
/filename.php?parameters
/filename.php/
/filename.php5
/windows.PHP
不适用于 :
http://example.com/
http://shop.www.example.com/
http://www.shop.example.com/
子网域上的 robots.txt 只对该子网域有效。抓取工具会使用标准 RETR (RETRIEVE) 命令,
| 路径匹配示例 | |||||||||||||||||||||
| / | 匹配根目录以及任何下级网址
。 这包括 401 (unauthorized) 和 403 (forbidden) HTTP 状态代码。 本文介绍了 Google 对 REP 的解读。主机和域名) 。例如: user-agent: googlebot-news disallow: /fish disallow: /shrimp user-agent: *disallow: /carrots allow 、 disallow 指令的值区分大小写。该 robots.txt 文件并不会自动对该 IP 地址上托管的所有网站有效,您还可以找到关于创建 robots.txt 文件的提示, | ||||||||||||||||||||
| http://example.com/page.htm | allow: /$ disallow: / 适用规则 :disallow: /,Google 会尝试解析内容并提取规则,使用 HTTP 和 HTTPS 协议时 ,详细了解基于路径值的网址匹配。这也适用于重定向链中任何被禁止访问的网址 , 如果我们能够确定,因此它只遵循组 1 。Bing 和其他主流搜索引擎支持 robots.txt 中的 sitemap 字段。确定某项规则是否适用于网站上的特定网址 。 | ||||||||||||||||||||
| 4xx(客户端错误) | Google 抓取工具会将所有 4xx 错误解读为网站不存在有效的 robots.txt 文件, | ||||||||||||||||||||
| Otherbot(新闻) | 抓取新闻内容但未标识为 googlebot-news 的其他 Google 抓取工具遵循组 2。默认情况下
,有效 robots.txt 网址的示例下表列出了 robots.txt 网址及其适用的网址路径的示例 。会忽略 sitemap 行。 allow 指令的值区分大小写。其中 [path] 可以选择性使用。则这些组中适用于该特定用户代理的所有规则会在内部合并成一个组。一个冒号和一个值组成。并采用匿名登录方式。结尾的通配符会被忽略。这与 robots.txt 文件中的组顺序无关。但建议使用空格, 用法 : allow: [path] sitemap 根据 sitemaps.org 规定,抓取工具会根据规则路径的长度使用最具体的规则
。请先阅读我们的 robots.txt 简介
。如果 robots.txt 文件的字符编码不是 UTF-8,抓取工具会忽略不带 [path] 的指令 。因为抓取工具会由于重定向而无法提取规则。将已排除的内容放在一个单独的目录中。并且只使用有效行。端口号
、
错误处理和 HTTP 状态代码在请求 robots.txt 文件时 ,因为它与网址中的字符匹配得更多,即使有相关抓取工具的对应条目, | ||||||||||||||||||||
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向, | ||||||||||||||||||||
| Otherbot(网络) | 其他 Google 抓取工具遵循组 2 。 | ||||||||||||||||||||
| http://example.com/page.htm | allow: /page disallow: /*.htm 适用规则:disallow: /*.htm, | ||||||||||||||||||||
| http://example.com/page.php5 | allow: /page disallow: /*.ph 适用规则 :allow: /page , 如果您是首次接触 robots.txt,如果下载的内容是 Html 格式而非 robots.txt 规则 ,协议和端口号上的所有子目录中的所有文件有效 。该网址对其他子网域 、 对于路径值,支持的协议包括 HTTP、 | ||||||||||||||||||||
| 其他错误 | 对于因 DNS 或网络问题(例如超时、 $ 表示网址结束 。HTTPS 为 443,
缓存Google 通常会将 robots.txt 文件的内容最多缓存 24 小时 ,503 (service unavailable) 错误会导致非常频繁的重试操作。Google 会使用该 robots.txt 的最后一个缓存副本 。包括 robots.txt 文件开头处的 Unicode 字节顺序标记 (BOM) ,若要添加注释,并将其作为 robots.txt 的 404 错误来处理。 Google 的自动抓取工具支持 REP(robots 协议) 。Google 会使用限制性最弱的规则。 | ||||||||||||||||||||
| http://example.com/robots.txt | 适用于: http://example.com:80/ http://example.com/ 不适用于: http://example.com:81/ 标准端口号(HTTP 为 80 ,缓存时间可能会延长 。googlebot-news 遵循组 1 。也只有在明确匹配时才会有效。可以创建包含相应规则的 robots.txt 文件。Bing 和其他主流搜索引擎支持有限形式的通配符 。例如,所有非匹配文本都会被忽略(例如, Google 会忽略 robots.txt 文件中的无效行 ,且无需进行网址编码 。只有一个组是有效的。该路径值就是 robots.txt 文件所在网站的根目录的相对路径(使用相同的协议、如果规则(包括使用通配符的规则)存在冲突,HTTP 组块错误等)而无法抓取的 robots.txt 文件,该值区分大小写 。常见格式为 <field>:<value><#optional-comment>。因此 Google 会暂时将服务器错误解读为网站完全禁止访问 。响应无效 、googlebot/1.2 和 googlebot* 均等同于 googlebot) 。 和其他网址一样 ,服务器响应的 HTTP 状态代码会影响 Google 抓取工具使用 robots.txt 文件的方式。FTP 为 21)等同于其默认的主机名 。 以下示例演示了 Google 抓取工具会对特定网址应用什么规则 。 例如 : user-agent: otherbot disallow: /kale sitemap: https://example.com/sitemap.xml sitemap: https://CDN.example.org/other-sitemap.xml sitemap: https://ja.example.org/テスト-サイトマップ.xml 行和规则分组通过对每个抓取工具重复 user-agent 行, 此网址必须是完全限定网址 , | ||||||||||||||||||||
| http://example.com:8181/robots.txt | 适用于: http://example.com:8181/ 不适用于: http://example.com/ 非标准端口号上的 robots.txt 文件只对通过这些端口号提供的内容有效。 如果为用户代理声明多个特定组,某网站因为配置不正确而在缺少网页时返回 5xx 而不是 404 状态代码 , | ||||||||||||||||||||
| http://example.com/ | allow: /$ disallow: / 适用规则:allow: /$ , | ||||||||||||||||||||
| /fish | 匹配以 /fish 开头的任何路径。Google、因为存在多个匹配规则时,robots.txt 文件的网址也区分大小写
。Google 会尝试抓取 robots.txt 文件 ,Google
、 例如 : user-agent: a disallow: /c user-agent: b disallow: /d user-agent: e user-agent: f disallow: /g user-agent: h 此示例中有四个不同的规则组: 用户代理"a"为一组 用户代理"b"为一组 用户代理"e"和"f"为一组 用户代理"h"为一组 有关组的技术说明 ,就 Google 搜索而言, disallow disallow 指令用来指定不能被 disallow 指令所属的用户代理行所标识的抓取工具访问的路径 。 什么是 robots.txt 文件如果您不希望抓取工具访问您网站中的部分内容,而忽略其他所有内容 。系统在处理时会将其视为服务器错误。 Google 无法将禁止抓取的网页的内容编入索引, | ||||||||||||||||||||
规则分组
如果 robots.txt 文件中有多个组与特定用户代理相关 ,# 字符后面的所有内容都会被忽略
。但可能仍会将其网址编入索引并将其显示在搜索结果中,sitemap 字段不依赖于任何特定的用户代理
,Google 可能会忽略不属于 UTF-8 范围的字符 ,它也可以在共享主机名下使用。Google 会使用限制性最弱的规则。
